Dear Suprema Patners & Customers,


If you are going to add 2nd generation device to BioStar 1.93 SW, please consider two parts.


1) FW compatibility

BioStar 1.93 doesn't support the most recent version of 2nd generation device. And, you can't add the devices to BioStar 1.93 with an error message.


BEW2 
: 1.3.0-20181115   

BS2 : 1.7.0_20181126 or higher version

BSA2 : 1.6.0_20190104   

BSL2 : 1.4.0-20181106  


Those FW can be not connected to BioStar 1.93.


(Relevant message)

Fail to read parameter from Device

Invalid Parameter


2) Downgrade Issue


Biostation A2

If you receive recently BioStation A2 product and you want to downgrade the version of A2, you can't downgrade the device successfully because of the sensor(OP6) compatibility. 

To distinguish the sensor type, you can prevent the issue if you confirm the serial number below. 

Please do not downgrade for the below list. The downgraded device will be malfunction and you should proceed it as RMA.


A2-OEPW : 939342346 ~

A2-OMPW : 939263914 ~

A2-OHPW : 939431431 ~

A2-OIPW : Not produced with OP6 yet. The schedule is not fixed.



BioStation 2 & BioEntry W2

You can downgrade W2 and BS2 without a HW problem, but please be aware that we can't ensure the compatibility between BioStar 1.93 and recent firmware except the below information.


2nd Generation Firmware Compatible with BioStar 1.93

BEW2 : 1.1.5 - 20171026

BS2 : 1.5.0 - 20170927

BSA2 : 1.4.0 - 20170927

BSL2 : 1.2.4 - 20170830




In conclusion,  we highly recommend to use BioStar2 SW if you have 2nd generation device.   


To support the DB migration from BioStar 1 to BioStar 2, we are going to release a DB converter tool.


If you have any inquiry about the above information, please create new ticket.