Affected Version: BioStar 2 Software Version 2.9.3

Fixed: V2.9.6 (Planned)

Article Updated: April 11, 2024


Summary of Issue Symptoms

BioStar 2 Restore tool returns the failure message when you try to restore the backed-up database using the BioStar 2 Backup tool.

  • NOTE: This issue occurs on the sites where the customers backed up the database using BioStar 2 Version 2.9.3, without restoring in the same BioStar 2 Version 2.9.3 BUT tried restoring database after the UPGRADING the BioStar 2 from V2.9.3 to V2.9.4

 

Cause of the issue

The BioStar 2 version of the "manifest.json" file in the .zip file backed up through the BioStar 2 Backup tool keeps V2.9.3. So, the BioStar 2 Restore tool detects the backed-up .zip file is from an incorrect BioStar 2 version.



Solution

Step 1. Apply the patch according to the guide and run the RESTORE tool again.

  • Stop BioStar 2 services at BioStar Setting.
  • Download the patch. FISS-3821.zip 
  • Unzip the patch and place it at <C:\Program Files\BioStar 2(x64)>.
  • Start BioStar 2 services at BioStar Setting.
  • Run the RESTORE tool again.
Excpetional Case Example] You were using BioStar 2 Version 2.9.3, and backed up the database in version 2.9.3. Now, you have upgraded your BioStar 2 Version 2.9.3 → 2.9.5 and currently using Version 2.9.5. 
So, your current installation path of <C:\Program Files\BioStar 2(x64)> will be for version 2.9.5 



Step 2. Restore manually the backed-up databases and files according to Suprema's guide below:


Step 3. Modify the "manifest.json" file in the text editor with an administrator privilege.

  • Open the "manifest.json" file from the .zip file, backed up from the BioStar 2 Backup tool in the text editor with an administrator privilege (e.g., notepad, etc.).

  • Find the "biostar_version" part and edit the version to the right one from which your database was backed up.
  • Save the "manifest.json" file.
  • Re-run the BioStar 2 Restore tool at C:\Program Files\BioStar 2(x64).