問題
突然、有効な管理者ID / PWでBioStar2 SWにアクセスできなくなりました。
関連するケース
原因
この問題は、BioStar2サービスの使用中にポート9000またはポート9001を別のアプリケーションに使用すると発生する可能性があります。
分析する方法
1) C:\Program Files\BioStar 2(x64)\logsでbiostar_YYYY-MM-DDをメモ帳で開きます。
以下のログを確認します。
- Failed to open fastcgi socket. port:9000 in use by another application
2) Chromeで[F12]を押し、[502 bad gateway, failed to parse decrypted text]エラーがあるか確認します。
解決方法
ポート番号が別のアプリケーションで使用されているかどうかを確認します。
まず、ポート9000とポート9002を確認します。
-BioStarはポート9000を使用するため、setting.confを手動で更新することで変更できます。(BioStar v2.7.5以降のバージョン)
[BioStar2] ポート競合を回避するためにポート9000を変更する方法
このソリューションで問題が解決されない場合は、データベース接続とサービスステータスを確認してください。
次の記事を参照してください
: [BioStar 2] BioStar 2サービストラブルシューティングチェックリスト
関連記事
[BioStar 2] BioStar2ログイン失敗不具合-biostar exit. restart biostar process
参考までに、ポートを変更したい場合は、BioStar v2.6> Portメニューからのみ変更できます。 以下のリンクを参照してください。