影響のある製品

BioStar 2


概要

1)BioStar 2の[ユーザー]メニューで、ユーザー情報をCSVエクスポートします。

2)CSVファイルをExcelで開いてユーザー情報を修正します。

3)更新されたCSVファイルをBioStar2ユーザーメニューからインポートします。

4)以下のように、日付形式をサポートしないエラーポップアップが表示されます。 



原因

BioStar 2からCSVエクスポートされたファイルをダブルクリックしてExcelで実行すると、Excel側で日付やカードIDをBioStar2でサポートしない形式に自動的に変換します。フォーマットを変換した後、BioStar 2からCSVをインポートしようとすると、エラーが発生します。サポートしない形式を含むCSVファイルであるため、インポートが出来ません。



ソリューション

  • BioStar2からCSVでエクスポートされたファイルをExcelでダブルクリックして開かないでください。


ソリューション#1. 管理者権限でメモ帳を開いて、BioStar2からエクスポートしたCSVファイルを編集します。


ソリューション#2. エクスポートされたCSVファイルを開いて、以下のガイドに従って、Excelから直接フォーマットを「テキスト」に変換します。


1> BioStar 2からCSVをエクスポートします。

2> Excelを開きます。

3> 'ファイル > 開く'を選択しBioStar 2からエクスポートしたファイルを開きます。

4> テキストウィザードで以下の手順で選択します。手順3では、列全体を選択して(黒くなります)、「テキスト」形式に変更する必要があることに注意してください。


5> CSVファイルを開いたら、必要なユーザー情報を追加および変更して保存します。

6> CSVインポートを介してBioStar2からファイルをインポートすると、成功します。