To access BioStar2 Cloud, ngrok.exe should be running on BioStar2 Server PC.
If you have the below error message while you are trying to access BioStar2 Cloud, refer the below instruction.
<Relavant Error>
1)
Cannot allow tunneling because the domain[yourdomainname.biostar2.com](version[] status[Unknown]) is not a valid version.
BioStar2 Cloud Registration Error: There is no data to process
<Relavant Problem>
Can't start ngrok.exe.
Can't access BioStar2 Cloud
Can't login for the verification link of BioStar2 Cloud
<Cause>
If there are many ngrok.log data in C:\Program Files\BioStar 2(x64)\logs, ngrok.exe is NOT started properly.
<How To Resolve>
1. Go to C:\Program Files\BioStar 2(x64)\logs and open nginx-service.log.
2. Confirm the below error code.
2019/10/31 06:14:35 => RunApp execute : C:\Program Files\BioStar 2(x64)\ngrok\ngrok.exe, arg : ngrok\ngrok.exe -config="C:\Program Files\BioStar 2(x64)\ngrok\ngrok.yml" -log="C:\Program Files\BioStar 2(x64)\logs\ngrok.log" start ac ta video
2019/10/31 06:14:36 => ngrok.exe start failed, error code = 2
3. Stop BioStar2 Server
4. Go to C:\Program Files\BioStar 2(x64)\logs and delete all ngrok.log files. (i.e. ngrok.log, ngrok.log.1, etc)
5. Restart BioStar2 Server
6. Confirm if you can access BioStar2 Cloud.