Productos y versiones afectados

Todas las versiones

 

Resumen

Durante la actualización de BioStar 2, aparece el proceso de "Comprobación de licencia" aunque el servidor tenga una licencia adecuada o no sea necesario.

En este momento, no activa ninguna licencia, incluso si inserta su licencia existente.


Causa 
 El servidor Java con la opción de comprobación de licencia no pudo iniciarse correctamente debido a problemas de proceso (conflicto de puertos de eq.)

 

Caso 1. Servidor spring

Error msg en acs.log :

java.net.SocketException: No hay espacio de búfer disponible (¿conexiones máximas alcanzadas?): JVM_Bind

 

Caso 2.  Servidor de verificación de licencias

Error msg en las ventanas de la consola de comprobación de licencia:

El conector Tomcat configurado para escuchar en el puerto 28148 no pudo iniciarse. Es posible que el puerto ya esté en uso o que el conector esté mal configurado.

 

Solución

Reinicie el servidor e inténtelo de nuevo

 

 

Si el problema persiste después de reiniciar el servidor, cree un ticket y cargue la carpeta y captura de pantalla de BioStar 2-logs del error con una explicación detallada del síntoma.