Affected Products & Versions

All versions


Summary

During the BioStar 2 upgrade, the 'License check' process appears even though the server has an appropriate license or is not required.

At this time, it doesn't activate any license even if you insert your existing license. 


Cause 
The Java server with the license check option couldn't start properly due to process problems(eq. port conflict)


Case 1. Spring server

Error msg in acs.log : 

java.net.SocketException: No buffer space available (maximum connections reached?): JVM_Bind


Case 2.  License check server

Error msg in license check console windows :

The Tomcat connector configured to listen on port 28148 failed to start. The port may already be in use or the connector may be misconfigured.


Solution

Restart the server and try again



If the issue persists after rebooting the server, please create a ticket and upload BioStar 2\logs folder & screenshot of the error with a detailed explanation of the symptom.