- 内容
BioStar 2にログインするとすぐに強制的にログアウトする
- 原因
TAログイン失敗。
F12キーを押して、以下のようにTA(ポート番号3000)の「ログアウト」に関するエラー応答があるかを確認してください。
BioStar 2がTA APIにアクセスする場合、ブラウザーにポート3000で入力されたIPを使用しますが、BioStar 2がTAにアクセスできない場合に発生します。
- ソリューション
i) TAを含むBioStar 2ポートが他のプログラムで使用されているかを確認します。[BioStar 2] サーバー及びデバイスポートの使用
ii) BioStar2サーバーのPCに内部IPアドレスがあり、パブリックIPアドレスを介してアクセスできるかどうかを確認します。 パブリックIPアドレスを介してBiostar2サーバーのPC上のBioStar2ページにアクセスできないことを確認してください。
パブリックIPアドレスを使用してBioStar2サーバーのBioStar2ログインページにアクセスできない場合は、BioStar2 TA DBのテーブルsystemsetting.biostar_tnaのデータを更新する必要があります。
ソリューションII適用方法
> 1. BioStar2すべてのサービスを停止します。
> 2. C:\Program Files\BioStar 2(x64)\ta\dist\lib\config\environmentに移動しproduction.jsのバックアップファイルを作成します。
> 3. production.jsをメモ帳で開きます。
> 4. ENABLE_AUTO_UPDATE_BIOSTAR_URLを[true]から[false]に変更します。
>4. ファイルを保存します。
> 5. BioStar2 TA DBに移動し、システム設定のbiostar_server_urlのデータをBiostar2サーバーの内部IPアドレスとして編集します。
>6. 正しく更新されているか確認してください
>7. Biostar2サービスを開始します。
問題が上記の状況と異なる場合は、以下の情報をテクニカルサポートチームに提供してください。
1. Chromeのネットワークスクリーンショット
2.すべてのBioStar 2ポートのポート使用状況のスクリーンショット
3. systemsetting.biostar_tnaとbiostar_server_url経由の接続のスクリーンショット
4. ipconfig情報
5. BioStar 2サーバーのプライベートIPおよびパブリックIP