Affected Product: BioStar 2
Versions: V2.9.4 and V2.9.5
Fixed: V2.9.6 (Planned)
Article Updated: October 25, 2023
Summary
The BioStar 2 Restore tool returns the failure when you try to restore the backed-up database from the BioStar 2 Backup tool.
- NOTE: This issue occurs on the sites where the customers UPGRADED the BioStar 2 from V2.9.3 to V2.9.4 or V2.9.5.
User Scenario
- Upgrade the BioStar 2 from V2.9.3 to V2.9.4 or V2.9.5.
- Perform a backup on the server with the BioStar 2 Backup tool.
- Install the new/fresh BioStar 2. (It will be V2.9.4 or V2.9.5, depending on the version which the customer backed up the database.)
- Attempt to restore database and files with the BioStar 2 Restore tool.
- Failure occurs, as shown in the image above.
Cause
The BioStar 2 version of the "manifest.json" file in the .zip file backed up through the BioStar 2 Backup tool keeps V2.9.3. So, the BioStar 2 Restore tool detects the backed-up .zip file is from an incorrect BioStar 2 version.
Solution
1. Apply the patch according to the guide and run the RESTORE tool again.
- Stop BioStar 2 services at BioStar Setting.
- Download the patch. FISS-3821.zip
- Unzip the patch and place it at <C:\Program Files\BioStar 2(x64)>.
- Start BioStar 2 services at BioStar Setting.
- Run the RESTORE tool again.
2. Restore manually the backed-up databases and files according to Suprema's guide below:
- Maria DB: [BioStar 2] Database Backup and Restore Instructions (Maria DB)
- MSSQL: [BioStar 2] MSSQL Database Backup and Restore Instructions
3. Modify the "manifest.json" file in the text editor with an administrator privilege.
- Open the "manifest.json" file from the .zip file, backed up from the BioStar 2 Backup tool in the text editor with an administrator privilege (e.g., notepad, etc.).
- Find the "biostar_version" part and edit the version to the right one from which your database was backed up.
- Save the "manifest.json" file.
- Rerun the BioStar 2 Restore tool.